Votre adresse IPv4 :
Système d'exploitation:
Fournisseur:

SPF, DKIM et DMARC : authentification du courrier

SPF autorise les hôtes d’envoi pour le domaine d’enveloppe, DKIM signe une partie du message avec une clé de domaine et DMARC vérifie l’alignement des identifiants tout en publiant politique et rapports. La réussite d’un seul mécanisme ne prouve pas la légitimité du message.

Le rôle de SPF, DKIM et DMARC

SPF vérifie si le serveur expéditeur est autorisé par la politique du domaine envelope-from ; DKIM vérifie une signature cryptographique portant sur certaines parties du message ; DMARC relie ces résultats au domaine From visible grâce aux règles d’alignement et publie une politique de traitement.

Comment vérifier les résultats d’authentification

Repérez Authentication-Results dans les en-têtes et vérifiez SPF, DKIM et DMARC séparément. DMARC dépend aussi de l’alignement avec le domaine From visible. Un résultat pass authentifie des relations de domaine, pas la fiabilité du contenu ou de l’intention. Vous pouvez recouper les données DNS du domaine avec vérification de réponse DNS 2ip avant d’interpréter Authentication-Results.

Pourquoi un pass ne signifie pas « message sûr »

Références techniques: RFC 7208, RFC 6376 et RFC 7489.